View unanswered posts | View active topics It is currently Thu Oct 19, 2017 4:23 am



Reply to topic  [ 1 post ] 
 Exchange 2016 OWA & ECP Chrome error 
Author Message
Site Admin

Joined: Tue Apr 05, 2011 12:19 pm
Posts: 10
When Using Chrome (and apparently Firefox) get below error message when trying to access Exchange 2016 OWA & ECP (Exchange Admin Centre).

Your connection is not secure

The website tried to negotiate an inadequate level of security.

XXXXXXXXXX.domain uses security technology that is outdated and vulnerable to attack. An attacker could easily reveal information which you thought to be safe. The website administrator will need to fix the server first before you can visit the site.

Error code: NS_ERROR_NET_INADEQUATE_SECURITY

or

This site can’t be reached

The webpage at https://mail.yoursite.com/owa might be temporarily down or it may have moved permanently to a new web address.

ERR_SPDY_INADEQUATE_TRANSPORT_SECURITY


Internet explorer (IE) and Windows Edge work as expected

-----------------------------------------------------------------------------------
FIX


Fixed using IIS Crypto tool https://www.nartac.com/Products/IISCrypto

Selected Best practices button and Apply

----------------------------------------------------------------------------------

As per post on https://support.mozilla.org/en-US/questions/1143320


Wed Sep 20, 2017 1:21 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.